Problem description / Issue description

The VMC iSeries installation depends on many factors: Users, FTP availability, Objects blockage, etc. This guide should help you diagnose the cause of the error.

Step 1

In order to know exactly what went wrong, we need more information about this error from the installation's log.

You can get it running: DSPMSG T4_INSTALL/T4_INSTALL, if you don't find it there, you can look for it in QGPL library.

Once you've found it, we need you to find the last error entry in it, place the cursor there and please then press F1 and send us a the print screen of
that message.

In it press F9 and the displayed message will show you the information you need from the ftp job which was doing the installation to get its joblog.

Step 2

In addition to this information, we can also try to run again the installation manually from an interactive session, but verifying the some
system values, and changing the information level first:

1)check that this values are configured like this:

QALWOBJRST ----> *ALL, ( running: DSPSYSVAL SYSVAL(QALWOBJRST) )
QALWUSRDMN ----> *ALL ( running: DSPSYSVAL SYSVAL(QALWUSRDMN) )
QVFYOBJRST ----> 1 ( running: DSPSYSVAL SYSVAL(QVFYOBJRST) )
QFRCCVNRST ----> 0, 1 o 2 (running: DSPSYSVAL SYSVAL(QFRCCVNRST ) ) (only V6R1)

2) Please, run this command: CHGJOB LOG(4 00 *SECLVL) This will change your interactive session message level into SECLVL.

Then run this installation command again: T4_INSTALL/INSTALL

Step 3

If the command fails again, you will have a spool file for the current user. You can get it with DSPJOBLOG OUTPUT(*PRINT)

This will generate a spoolfile that you can get as a text file using Operations Navigator (you'll need to log with the same user you run the installation -remember it must be a *SECOFR user-; then go to: basic operations -> printer output and in the right side you'll see all the spoolfiles generated. If you select the joblog you can drag and drop it into any windows folder and you'll get it as a text file)

Step 4

We can also try to reinstall completely the product.

In order to do this, log on with a *SECOFR user and please make sure that there isn't any Tango Library on your system:

1) Check that T4NICELINK or JOBCTL subsystems are not active.

2) Verify that there isn't any locked object running:

wrkobjlck t4nicelink *lib and wrkobjlck b_detector *lib and wrkobjlck jobctl *lib

3)RMVJOBQE SBSD(QSYS/QSYSWRK) JOBQ(T4NICELINK/STRSBSNLK)

4) Then if they exist and there is no locked object please delete the following libraries: T4NICELINK, T4_INSTALL, JOBCTL, VISUALW and B_DETECTOR

5) Finally try to run again the installation using the CD or the Installation file

 

Note:

Please, after the installation (automatic or manual) check if the object: B_DETECTOR type *AUTL (authorization list) was created successfully and that is has all the objects of the B_DETECTOR library, plus the B_DETECTOR library itself.


Still have questions? We can help. Submit a case to Technical Support.

Last Modified On: November 06, 2019