Posted Tue, 04 Feb 2020 14:47:44 GMT by Carolina Pereira

Good afternoon,

I have Automate Plus 11.1.30.3 and times a times Automate shows the message "No connection between management and execution servers" and I can not execute tasks.

I don't have adminstrator privileges so I can not restart the Automate services.

I am solving this problem by restart my machine, but this is not a good solution.

 

Do you have any suggestion on how to solve this problem?

 

Posted Tue, 04 Feb 2020 15:05:52 GMT by Justin Aucoin

 

Hi Carolina,

One method customers have used to help alliveiate this issue is to create a Workflow with a task that stops and then starts the Automate Enterprise 11 Management service. This is the only service that needs to be restarted when this issue occurs. The task can be given the credentials of an administrator and set to run with highest privileges to allow this. Depending on the server's security settings, the task may need to be run from a local agent or a remote agent. I have included an example of the this workflow attached with both varients of the task.

Posted Tue, 04 Feb 2020 16:36:51 GMT by Carolina Pereira

This method only works if I am the administrator of the machine.

Is there any other solution where it is not necessary to have administrator privileges on the machine?

 

Thanks for the quick answer.

Posted Tue, 04 Feb 2020 16:44:30 GMT by Justin Aucoin

Hi Carolina,

 

The connection will not re-establish until the Management service is restarted.  You could, if the user has correct permissions, have Automate Restart the Execution server with a local agent at and off hour time on a schedule.  But this this would be the only other method.  You can also check with your system administrators and they could set a user with admin privileges in the restart Management services task only by overriding the logon settings in the Workflow or Task properties.

Posted Tue, 11 Feb 2020 17:44:28 GMT by Carolina Pereira

Hello,

I received an email reporting a post in response to my question, but I can not see Justin Aucoin's answer to my question.

Can you post the reply again?

 

Thank you. 

Posted Tue, 11 Feb 2020 18:02:47 GMT by Carolina Pereira

Now that I've made a new post, I can see Justin's response.

Thank you

Posted Wed, 20 May 2020 18:21:53 GMT by Joe Hamilton

Hi,

Will restarting the management service cause failures to any jobs in progress or jobs that are scheduled?

Posted Wed, 20 May 2020 18:27:58 GMT by Carolina Pereira

Hello,

I received an email about new content in this post, but I can't see.

Thank you.

Posted Thu, 21 May 2020 20:44:34 GMT by Alex Escalante

Hello Joe,

Restarting the management service alone will not hinder or interrupt the job execution of AutoMate.

You must be signed in to post in this forum.