Posted Tue, 28 Aug 2018 20:46:45 GMT by Eldon Balzer

Just went through an OS upgrade from Ubuntu Server 16.04.5 to 18.04.1

Intermapper itself is running and operating fine.  As part of the upgrade process Ubuntu disables all 3rd party sources.  I've gone through the steps posted in the installation readme to add the dartware repository again.

I know the dartware repository was using a weak key strength as it was always complaining on 16.04 already.  Now I cannot add it at all without getting verification errors:

[email protected]:/etc/apt# curl --output dartware_public_key.asc -L http://www.intermapper.com/go.php?to=gpgkey
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   185  100   185    0     0   1045      0 --:--:-- --:--:-- --:--:--  1045
100   279  100   279    0     0    680      0 --:--:-- --:--:-- --:--:--   680
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100  1712  100  1712    0     0   1764      0 --:--:-- --:--:-- --:--:--  1764
[email protected]:/etc/apt# apt-key add dartware_public_key.asc
OK
[email protected]:/etc/apt# apt update
<REMOVED many lines here>
Reading package lists... Done
W: GPG error: http://download.dartware.com/debian ./ Release: The following signatures were invalid: 4E876D4B2C0945F14BC165F6DF7BA8CA6ACACF42
E: The repository 'http://download.dartware.com/debian ./ Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Just wondering if the apt-get method is still a supported feature for dartware/HelpSystems products?  I don't mind doing the manual upgrade method as I used  to do that.  Just found it more convenient to use Ubuntu's built-in update management ;)

 

 

Posted Wed, 29 Aug 2018 17:22:58 GMT by Mike Maki

Hello Eldon,

Thanks for the report. Yes, the apt repository is still supported in InterMapper.

Debian and Ubuntu versions recently released and not yet supported under our system requirements have dropped support for SHA1 GPG hash calculation and now require SHA 256. Our repository needs to be updated for the change, and I've filed a report with our Development group asking for that change to be made. I don't have any information at this time regarding scheduling.

Mike Maki

InterMapper Support

You must be signed in to post in this forum.