Posted Fri, 10 May 2019 13:42:54 GMT by Steve Vold

If the version of Intermapper is 5.8 or higher, it will not require internet access because the registration is completed within the software itself. 

If the version of Intermapper is 5.7.1 or lower, please contact [email protected]m for further instructions. 

You must be signed in to post in this forum.