Posted Thu, 01 Jan 2015 06:00:00 GMT by Portal Admin

Follow this procedure to initialize intermapper database on Mac OS X.
If any questions, please contact me back and we can discuss.

From map list or map, click on Edit – Server Settings – Reports Server
If button at top has Stop written in it and it is showing report status,
click on the button and stop the collection.
Answer okay to prompt.
Open a browser to Intermapper Data Center
If on local host, https://127.0.0.1:8182
You may get prompted for certificate, just proceed to page
In the middle of screen is the Intermapper Database control
Click on the Stop button under Intermapper Database section
Display will say:
IMDatabase is not running

Open terminal window with sudo privilege
Run these commands:

sudo /usr/local/share/intermapper/Stop.sh
sudo launchctl unload -F /Library/LaunchDaemons/com.dartware.InterMapperDataCenter.plist

also verify all postgres daemons are stopped with this command
ps acux | grep postges

If you see postgres processes running, stop them also with
kill “process id”
the process id will be displayed in the above command

Change directory to /usr/local/imdc/config/database
Move the contents of the database folder to a temporary location
Leave the database folder there or Intermapper won’t start

While you have the database folder open, start Intermapper with following:

sudo launchctl load -F /Library/LaunchDaemons/com.dartware.InterMapperDataCenter.plist
sudo /usr/local/share/intermapper/Start.sh

Once the IMDC daemon is running, you should see the files and folders re-appear in the database folder

To verify processes, run these commands:

ps acux | grep intermapperd
ps acux | grep intermapperflows “if using”
ps acux | grep imdatacenter

Open the IMDC web page again
Click on database (start) button on web page
You will see some messages flash up
One of these is the creation of the database
It will come back and show
Connected to internal database; no servers registered for reporting

Go back into Server Settings – Reports Server
Click on Start button for Data Collection for Reports
The Start button changes to Stop again
And you should see messages about the report status sending data to database
Also on the corresponding IMDC web page you will see status there of imports
Click on the More Details if not seeing the status line in the web page.

On the Server Settings – Reports Server window,
Set the date and time of the oldest data you want to import into the database
Select the method of import from the chart files into the database
Intermapper performance may be affected by this setting.
We normally recommend gradual or nightly

This should clear up your database errors
Once some data has started to get imported,
Verify that the reports are correct for the data it will have imported at that point
Delete the old database folder and files from your temporary location from above.

You must be signed in to post in this forum.