Posted Thu, 01 Jan 2015 06:00:00 GMT by Portal Admin

Q: When I am using intermapper it is only showing reports over a two day period and nothing in the past.

A: It sounds like the data retention policies need to be adjusted for your installation to meet the reporting requirements.

You can check what data retention policy applies to datasets of interest in the Dataset View for any map.

To select all devices, click in the left column,then type control-A. Control-click toggles selection to allow dropping devices you don't care about data for. Once the devices are selected, the space bar will toggle the check box selection.

To see configuration of the data retention policy settings, use Edit > Server Settings > Retention Policies. Existing policies may be edited or new ones added using this tool.

A word of caution about retention policies - the Chart Data column needs to be set to Forever in order to save the data in the InterMapper Database as the architecture currently functions. This will cause the growth of the Chart Data directory in direct proportion to the number of datasets saved.

Many users find it gets quite large.

Please monitor the InterMapper Settings/Chart Data folder for growth rate following changes to data retention in order not to develop storage issues.

It is much easier to not save data than to delete it later from Chart Data, since this is a manual process (currently no age-out mechanism is provided as with the database).

ref:

Retention Poloicies
Data Collecting and Reporting

About Retention Policies
InterMapper Settings

You must be signed in to post in this forum.