Posted Wed, 14 Apr 2021 16:05:46 GMT by Network Administrator

I have been running Intermapper Remote Access on various Debian based Liuxes for several years.  Recently have been seeing new installs fail with a dialogue box that says:


Java 11.0.2 or later is needed to run this application
You should install OpenJDK JVM: https://openjdk.java.net
java.vendor = Debian
java.runtime.name = OpenJDK Runtime Environment
java.runtime.version = 11.0.9+1-post-Debian-1deb10u2

This morning I quit IRA and restarted it, and got this dialogue.  This machine is running Linux Mint Debian Edition 4, which is based on Debian 10 (Buster).

Obviously the java version checker has a broken parser, since the runtime version is 11.0.9, which is definitely later than 11.0.2, and it is the recommended OpenJDK jre.  This behaviour is at least in Intermapper Remote Access 6.3, 6.4, and 6.5, and at least 2 versions of Debian OpenJDK-11. 

The document at https://static.helpsystems.com/intermapper/pdfs/intermapperinstallation.pdf says that the installer installs a JRE to run the client, however it does not appear to do so.  Just in case the installer only installed a JRE if it could not find one I completely removed Java from my machine and reinstalled the client. It did not install a JRE, and it obviously failed to start with an "unable to locate Java" error.

Do I need to download and install a clean OpenJDK reference implementation just to run Intermapper Remote Access?  I really try to avoid running multiple Java environments on my machine, especially when they are the same version of Java.

Thanks for any advice,

Tim

Posted Wed, 14 Apr 2021 16:23:55 GMT by Network Administrator

Just an update, I removed all java from my machine, cleanly installed OpenJDK reference implementation (build 11+28), pointed environment variable $INTERMAPPER_JAVA at the location of the java interpreter, and got the same dialogue box as with the Debian OpenJDK version.

Tim

Posted Wed, 14 Apr 2021 20:58:20 GMT by Steve Vold

Hi Tim,

We are including this fix in 6.5.2 which is coming out soon. For now, using Debian/Ubuntu Linux, use the following to ensure a usable Java is installed:

sudo apt install openjdk-11-jdk

It is possible a headless version lacking the libraries needed to run the Java GUI is installed instead, which will not launch the user interface. Check this using:

apt list --installed | grep jdk

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

openjdk-11-jre-headless/bionic-updates,bionic-security,now 11.0.10+9-0ubuntu1~18.04 amd64 [installed,auto-removable]


Thanks,

Steve Vold
603.643.9600 | www.helpsystems.com

Posted Thu, 15 Apr 2021 13:16:56 GMT by Network Administrator

From your post, I am assuming that Ubuntu 18.04 has updated to java 11.0.10, Debian stable has not. 

I normally run openjdk-11-jre, but in troubleshooting this problem I have installed the full JDK as well as trying the reference implementation from Oracle.

I will try a manual install of a later version.  Mixing Ubuntu and Debian repositories on an apt based linux tends to lead to admin headaches, so I will just put a newer version of java in the directory with remote access.  I see that it checks for an environment variable then a local java before trying the system java, so I will give that a try.  I decompiled CIntermapperClientMain.class to look at the java version checker code, I honestly don't see why it doesn't work, unless for some reason the Debian java is returning a non standard value for system property java.version.

Thanks for the reply

Tim

Posted Thu, 15 Apr 2021 16:35:27 GMT by Network Administrator

Installed a fresh install of Oracle OpenJDK-11.0.10 in an alternate path, pointed $INTERMAPPER_JAVA at it, it is now working, and doesn't interfere with the system 11.0.9 JRE.

Thanks for the help.

Tim

You must be signed in to post in this forum.