Posted Fri, 10 Jul 2020 18:42:56 GMT by Jason Robertson

Is there a work around to get RemoteAccess 6.5 working with java 1.8.0_251 on ubuntu 18.04?

 

See below:

 InterMapper_RemoteAccess_6.5 java -jar intermapper_remoteaccess.jar
Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/dartware/intermapper/CInterMapperClientMain has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:756)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:468)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:74)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:369)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:363)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:362)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:418)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:355)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:351)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495)
➜  InterMapper_RemoteAccess_6.5 java -version                         
java version "1.8.0_251"
Java(TM) SE Runtime Environment (build 1.8.0_251-b08)
Java HotSpot(TM) 64-Bit Server VM (build 25.251-b08, mixed mode)

Posted Fri, 10 Jul 2020 19:42:49 GMT by Mike Maki

Hi Jason,

Our Readme file for InterMapper RemoteAccess is in error. Sorry if you installed Java 8 as a result. If you don't use it for anything else, please remove it.

Our installer contains OpenJDK 11 which we'll use to run the IM RemoteAccess client. If you defined any environment variables to point to Java 8, please also remove those.

I run IMRA 6.5 on Ubuntu 18.04 on one of my test VMs, and it works fine.

I've filed a defect report to get the reference to installing Java removed from the Readme. Again, our apologies.

If there is any further issue getting up and running, please email [email protected] and we'll help get it sorted out.

best regards,

Mike Maki

InterMapper Support

You must be signed in to post in this forum.