Posted Thu, 01 Jan 2015 06:00:00 GMT by Portal Admin

Q:  The server port is 8185 instead of 8181 under InterMapper Control Center and now I'm having troubles logging in. Control Center displays a message "Cannot log in in to InterMapper"
Is there any way I can change the port number back to 8181?

A:  Stop InterMapper, then restart it by launching the binary using the --port option.

On OS X, check whether the InterMapper process is running, either:

1. Using InterMapper Control Center (menu bar application) check whether it is running and stop it, or

2. By using "ps -ef |grep intermapperd", determine the Process ID (if running) and use "kill -9 " to stop it if so.

then start it from a Terminal using

sudo /usr/local/intermapperd --no-daemonize --port 8181 &

On Linux, use method 2 above to check whether the process if running, then if so use:

sudo /etc/init.d/intermapperd stop

to stop it. Restart it using the same command with the --port switch, for example:

sudo /usr/local/bin/intermapperd -f /usr/local/etc/intermapperd.con --port 8181

On Windows, use the Control Panel > Administrative Tools > Services to stop the InterMapper service if running.

Then open a Command Prompt, cd to C:\Program Files\InterMapper or, on a 64-bit Windows, C:\Program Files (x86)\InterMapper, and type

InterMapper.exe --no-daemonize --port 8181 to start the service

With the InterMapper daemon/service running, start the client as usual and use File > Server > Log Out to log off the server, then File > Server > Info to set the port to 8181, then OK to save the setting.

You must be signed in to post in this forum.