Posted Thu, 01 Jan 2015 06:00:00 GMT by Portal Admin

Forcing the InterMapper Server NOT to Run at Boot Time

Some customers have asked that InterMapper not start its server automatically when the system starts up. On MacOS X and Windows, InterMapper 4.5 offers a checkbox in the InterMapper Control Center to do this.

For earlier versions, or on other platforms, It is possible to disable the InterMapper Server's automatic capability of starting when the system boots up. The method depends on the OS running the software:

Windows XP, 2003, 2000, NT

Open the Services control panel. (This will always be accessible from the Administrative Tools panel in the control panels, also accessible other ways in various versions of Windows.) Right-click and choose Properties. Change Startup type to Manual. Click Ok.
MacOS X 10.4 (Tiger)

On MacOS X 10.4 (Tiger), InterMapper uses the LaunchDaemon to start/stop the server. You have to remove the InterMapperServer plist from /Library/LaunchDaemons. It is also possible to add a flag to the launchd plist to turn off the automatic reboot. Run the following command in Terminal to stop InterMapper and insert the flag into the plist:

sudo launchctl unload -w /Library/LaunchDaemons/com.dartware.InterMapperServer.plist


To restart intermapperd and clear the flag, pass -w on the command to load:

sudo launchctl load -w /Library/LaunchDaemons/com.dartware.InterMapperServer.plist


Mac OS X 10.3.x

Simply move the InterMapperServer item out of /Library/StartupItems. When you restart, the InterMapper server daemon will not be started.

Alternatively, the file /Library/StartupItems/InterMapperServer/InterMapperServer actually launches the daemon at boot time. You can rename that file to be "InterMapperServer/InterMapperServerDisabled".

To restore the boot-time launch of the InterMapper server, simply restore the file to its original name.

Linux

Many versions of Linux also have a way to do it in the GUI. For example:

* Red Hat and Fedora running KDE: Click the start menu (RedHat or squiggly f), choose Administration->Server Settings->Services and uncheck intermapperd in the Background Services tab. (Verified in Fedora Core 5; others might be slightly different.)

* Red Hat and Fedora running Gnome: Click the start menu, choose System Settings->Server Settings->Services and uncheck intermapperd. (Verified in Red Hat 9; others might be slightly different.)


If these facilities are not available, you should use the chkconfig command to enable or disable the automatic start. For example, turn it off using:

/sbin/chkconfig intermapperd off


This has the effect of removing both symbolic links listed below. Read the file /etc/init.d/intermapperd to find out how to recreate them.

Remove S97intermapperd from /etc/rc3.d
Remove K03intermapperd from /etc/rc6.d


Sun/Solaris

You must remove the proper files from two /etc/rc* directories:

Remove S97intermapperd from /etc/rc2.d
Remove K03intermapperd from /etc/rc0.d

You must be signed in to post in this forum.