Posted Wed, 25 Jul 2018 15:36:14 GMT by Rendell Guynes

Cannot get Gmail to work with SMTP for notifiers. I have not tried any other email services.

 

I've tried the settings listed here:

https://community.helpsystems.com/forums/intermapper/notifiers/958c81ce-fa83-e511-80d0-005056842064

And the non-SSL settings using aspmx.l.google.com, port 25 sending only to another gmail account.

https://support.google.com/a/answer/176600?hl=en

Posted Fri, 27 Jul 2018 13:33:09 GMT by Mike Maki

Hi Rendell,

I use smtp.gmail.com as the host and 587 as the port for this (in Server Settings > Email), and it's been working fine.

To see the connection for debug purposes, use Help > Diagnostics > Detailed Logs, and check the box for SMTP connections.

Then open the edit window for your email notifier and click the test notifier button. My connection looked like this:

Connect'd: SMTP connection to "209.85.200.108:587"
Recv'd:  220 smtp.gmail.com ESMTP c97-v6sm2603117itd.19 - gsmtp
Sent: EHLO [10.65.49.43]
Recv'd:  250-smtp.gmail.com at your service, [50.241.106.41]
Recv'd:  250-SIZE 35882577
Recv'd:  250-8BITMIME
Recv'd:  250-STARTTLS
Recv'd:  250-ENHANCEDSTATUSCODES
Recv'd:  250-PIPELINING
Recv'd:  250-CHUNKING
Recv'd:  250 SMTPUTF8
Sent: STARTTLS
Recv'd:  220 2.0.0 Ready to start TLS
Sent: EHLO [10.65.49.43]
Connect'd: SMTP connection to "209.85.200.108:587"
Recv'd:  250-smtp.gmail.com at your service, [50.241.106.41]
Recv'd:  250-SIZE 35882577
Recv'd:  250-8BITMIME
Recv'd:  250-AUTH LOGIN PLAIN XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER XOAUTH
Recv'd:  250-ENHANCEDSTATUSCODES
Recv'd:  250-PIPELINING
Recv'd:  250-CHUNKING
Recv'd:  250 SMTPUTF8
Sent: AUTH PLAIN AG1pa2VtYWswMDlAZ21haWwuY29tAGphbWVzYmxvbmQxOA==
Recv'd:  235 2.7.0 Accepted
Sent: MAIL FROM:<[email protected]>
Recv'd:  250 2.1.0 OK c97-v6sm2603117itd.19 - gsmtp
Sent: RCPT TO:<[email protected]>
Recv'd:  250 2.1.5 OK c97-v6sm2603117itd.19 - gsmtp
Sent: DATA
Recv'd:  354  Go ahead c97-v6sm2603117itd.19 - gsmtp
Recv'd:  250 2.0.0 OK 1532698070 c97-v6sm2603117itd.19 - gsmtp
Sent: QUIT
Recv'd:  221 2.0.0 closing connection c97-v6sm2603117itd.19 - gsmtp
Disconnect'd: SMTP connection to "209.85.200.108:587"

If the failure reason can't be corrected, please send a packet capture of a connection attempt to support.helpsystems.com and we'll open a support case.

best regards,

Mike Maki

InterMapper Tech Support

Posted Fri, 07 Feb 2020 20:59:42 GMT by Steve Vold

I believe this may be the solution needed for the gmail configuration. I'll create a separate article to help identify this. 

Test enabling “Access for less secure apps” (which just means the client/app doesn’t use OAuth 2.0 - https://oauth.net/2/) for the account you are trying to access.  It's found in the account settings on the Security tab, Account permissions (not available to accounts with 2-step verification enabled):  https://support.google.com/accounts/answer/6010255?hl=en

 

Thanks,

Steve Vold

Intermapper Support Representative 

You must be signed in to post in this forum.