Q. I recently upgraded my DHCP server from 10.4 server to 10.5 server, and now the DHCP probe returns an error: "No DHCP response."

A. It appears that the 10.5 DHCP server doesn't answer in time.

Here is a possible fix, from:
http://discussions.apple.com/thread.jspa?messageID=6640940

You need to manually edit the /etc/bootpd.plist configuration file. This is the file that stores all the DHCP server settings for Leopard Server. In this file there is an entry like this:

reply_threshold_seconds
10


 You need to change the value from 10, to 0 (zero). This will cause the DHCP server to respond straight away to requests. You then need to stop and start the DHCP server process (in Server Manager) to force it to re-read this setting and use it. Note that enabling Leopard's Internet Connection Sharing facility would reset that parameter back to 10.

This workaround has the added benefit of speeding up the response time of the DHCP server for actual DHCP clients.

As part of the DHCP protocol, the client includes the number of seconds it has been waiting; the Leopard DHCP server, by default, ignores request packets unless the client says it has been waiting for at least 10 seconds. In InterMapper 5.0, there is an option to override that number, so that InterMapper will claim to have been waiting for the number of seconds specified in the probe parameter, fooling the Leopard DHCP server into answering.