Instructions for creating an import file that will configure your map to use SNMPv3 to monitor your equipment


 InterMapper has the ability to import a file to set/update the configuration of the devices on the map. The import file can be a tab-
delimited, comma separated values (CSV), XML, or an HTML file. 

Here's the easiest way to do mass updates on a map:

- Export the data fields you wish to update to a CSV file
- Edit that file in a spreadsheet (Excel, OpenOffice, etc.) 
- Re-import that data file - InterMapper will update the fields that have changed

A couple guidelines:

- You *must* include the "Id" field - this is the unique identifier for each device on an InterMapper server, and any changes you
make will be applied to this device. 

- Some fields of a device are read-only, and cannot be modified. Any of the fields listed with a "+" in the Device Attributes page of the User Guide can be modified.

 To update a map:

1) Exporting the relevant data fields. Use the File -> Export -> Data File... menu choice. Choose which fields you wish to export
from the list on the left. Select whether to export all devices, only those on the map, or only the selected devices, then select an
export file format, then click Export. A good selection of fields is:

Map Name
Id    
Name
Address
... plus any other fields you wish to update, for example:
SNMPVersion
SNMPv3UserName
SNMPv3AuthProtocol
SNMPv3AuthPassword
SNMPv3PrivProtocol
SNMPv3PrivPassword

2) Edit the resulting file in a spreadsheet. The first line (called the "directive line") should not be modified. It contains the field
names at the top of each column, and allows InterMapper to map the columns back to the proper fields during the import process. 

Edit the columns to contain the desired data, leaving the Id column alone. Then save the file.

3) Re-import the updated data file. Use File -> Import -> Data File... and select the file. InterMapper will give an indication of how
many devices were updated. [InterMapper ignores and skips empty lines. You may see a warning about lines being skipped - check
the Event log file (Window -> Logs -> Event Log) to see the full results.

Other Notes:

- There is a comprehensive writeup of how to create a file for import in the InterMapper User Guide

- You can export/import other tables from InterMapper:

- The Vertices table describes the appearance of the icons on a map (icon, label, shape, font, etc) 
- The Interfaces table describes each of the interfaces (ifIndex, Description, Alias, PhysAddress, type, etc.)
- The Maps table describes characteristics of each map (Map name, path, device count, etc.)
- The Notifiers table gives the definition of each of the notifiers 
- The NotiferRules table describes the conditions under which a notifier fires
- The Users table describes each of the authorized users on the InterMapper server (Name, Password, Groups, etc)
- The Schema table describes the schema for each of the tables

- There is a full list of importable and exportable fields at: http://download.intermapper.com/schema/imserverschema.html