Note: Skybot Scheduler has been renamed to Automate Schedule and is now part of the Automate suite of products. The existing Skybot Scheduler features and functionality are the same; only the product name has changed.

Before You Install

Read this information completely before you install Automate Schedule on your Windows, UNIX, Linux, or PowerLinux server.

  • If there are any firewalls between your PC and the server, verify that your profile has access to the PC.
  • Your network must be configured and working using TCP/IP configuration.
  • UTF8 language files must be installed for AIX installations. To check if these files are installed, type the command locale -a. If the UTF8 language files are installed, you'll see entries with the first two letters capitalized (for example, EN_US.UTF-8 or EN_US).

    If you do not see any UTF8 language files installed, contact your AIX administrator to get them installed.

Enterprise Server Requirements

To use Automate Schedule, your enterprise (host) server must meet the following requirements:

Note: For Automate Schedule 4.3 and higher, a 64-bit operating system is required for Windows and Linux.

Supported
Operating Systems
Other
Required Software
Minimum Hardware
Requirements (all systems)

Windows Server 2016
Windows Server 2012 R2
Windows Server 2012
Windows Server 2008 R2
AIX 7.1 or 7.2 (Service Pack 2 or higher)
Red Hat Enterprise Linux 6 or 7
CentOS 6 or 7
SUSE Enterprise Linux 12
Ubuntu Linux 14.04 LTS, 16.04 LTS, or 18.04 LTS

Perl 5.6 or later (Linux/AIX)

4 GB RAM (8 GB+ recommended)
5 GB free space (25 GB+ recommended)

 

Unix and Linux Agents Software Requirements

To install Automate Schedule agents on your Unix or Linux system, your server must run one of the following operating systems:

  • AIX 7.1 or 7.2 (Service Pack 2 or higher)
  • HP-UX 11iV3 (PA-RISC or IA64)
  • SunOS / Solaris 10 or 11 (Sparc or x86)
  • SUSE Linux 12, or 15
  • Red Hat Enterprise Linux 5, 6, or 7
  • CentOS 5, 6, or 7
  • Ubuntu 14, 16, or 18

Note: Automate Schedule Agents that run on Java 1.6 or older will not work once updated to version 4.3.

You must also be running Perl 5.6 or later. Use the following command to find your Perl version:

perl -v

Windows Agents Software Requirements

To install Automate Schedule agents on your Windows system, your server must run one of the following operating systems:

  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2
  • Windows Server 2008 (must use 32-bit installer for version 4.3)
  • Windows 10 Professional
  • Windows 8 Professional
  • Windows 7 Professional

Note: Automate Schedule Agents that run on Java 1.6 or older will not work once updated to version 4.3.

Resource Requirements

  • 300 MB free space (includes JVM) as minimum recommendation
  • 75—125 MB of RAM for Agent processes

Still have questions? We can help. Submit a case to Technical Support.

Last Modified On: March 11, 2019