It's important that you read the following information before you attempt installing or upgrading QSystem Monitor V13, QMessage Monitor V8, or QRemote Control V4.

General Points

  • Review the installation and upgrade instructions for the product before installing or upgrading the software. You can access the instructions on our website:

    Installing QSystem Monitor
    Upgrading QSystem Monitor

    Installing QMessage Monitor
    Upgrading QMessage Monitor

    Installing QRemote Control
    Upgrading QRemote Control

  • Ensure that the profile being used to install or upgrade has the same authority and profile configuration (special authorities, password, and so on) across all systems or partitions.

  • Upgrades (from QMessage Monitor V7 or earlier to V8): Before upgrading, you'll need to obtain a new license key from HelpSystems. Download the Get System Information Tool from any of the product download pages and then run it. You can access the product download pages via the My Downloads page (for existing customers) or from the Free Trial email you received (for new customers).

    After the tool has started, enter the system IP address and a username and password with sufficient RSTOBJ authority on the system. The relevant system information is returned. Copy this information and return it via email to keys@helpsystems.com.

  • Upgrades: While using QSystem Monitor V12.5 or QMessage Monitor V7, you may have initiated the grace period processing feature. This feature allowed the product to remain active for a limited amount of time when a system's configuration exceeded your licensed usage. Grace period processing created licensed programs on your system. You can safely remove these CCSS licensed programs after upgrading to the new versions. To confirm whether they exist on your system, use the WRKLICPGM command and look for 8CCSSLC, options *BASE, 1, 2 and 3. If they exist, use the DLTLICPGM command to remove them.

 

Upgrades—Important License Key Information

Note: This section only applies to the following upgrades:

  • QSystem Monitor V12 or earlier to V13.
  • QMessage Monitor V7 or earlier to V8.
  • QRemote Control V3 or earlier to V4.

Due to changes made to our license key programs, the upgrade process is slightly different than in the past. The product cannot be fully started until the new license key programs have been installed and the new 75-character key applied. After you've finished upgrading to the new version, normal service will be resumed from that point onward.

  • Ensure that you have the new license key available before you start the upgrade. This can be a generic key or new permanent key. Note: Depending on your system setup, you'll likely have multiple keys - one per partition. Perform the following actions on each system.

  • Ensure that the product’s TCP server jobs are active on all the remote systems.

  • Start the upgrade from the earlier release using the installer in the usual manner.

  • After the host has finished upgrading, the upgrade jobs will be initiated on the remote systems.

  • The products will not auto-start on the host for this upgrade.

  • Wait for the upgrade jobs (U.) on all of the remote systems to complete.

  • Then, enter the keys on your host system.

  • Start the product as normal.

 

QSystem Monitor—Version 13

System Requirements

Before attempting installation onto either the IBM i or the PC, check that your hardware and software meet the minimum requirements set out below.

IBM i Requirements

  • Hardware: At least one partition running IBM i
  • Software: V5R4 or higher

PC Requirements

  • Software: Windows 7 or higher

Important Notes

  • Upgrades: It's recommended that you perform a backup of the QSystem Monitor product library on the host system in the days before the upgrade.

  • For information on mandatory and optional PTFs, see "QSystem Monitor PTF Requirements."

  • If you plan to use a large number (several hundred or more) of WebSphere MQ checks in QSystem Monitor, follow the steps outlined in IBM APAR SE35397 for WebSphere MQ before creating the checks.

  • If you are running V7.1 or higher of the operating system:

    • Database CPU usage (DCP) will always return a value of zero due to changes in the operating system. Therefore, it no longer needs to be displayed in the Monitor module.

    • CPU values that are reported in (and exported from) the Accounting Summary will be scaled in relation to the number of processors. For previous versions of the OS, the CPU values presented in (and exported from) the Accounting Summary module were not scaled.

  • If you plan to use the Limited Lock Mode disk collection feature, ensure that the latest Cumulative PTF Package for your release has been applied:

    http://www-912.ibm.com/s_dir/slkbase.nsf/recommendedfixes

  • Upgrades: Before upgrading to version 13, check whether libraries MSMUPG and MSMRMT exist on any of the systems. If they do and if they contain objects, then make sure that the libraries are cleared to accelerate the upgrade process.

  • If you are using HA software, ensure that libraries MSMFIX and MSMUPG are excluded from replication. This will ensure that the upgrade process runs smoothly.

  • QSystem Monitor version 13 contains an auto-upgrade function for the PC software. This allows the PC software to be upgraded automatically after the IBM i software has been upgraded. This functionality only applies from V13 onwards. The PC software will not be automatically upgraded from V12.50 to V13.

  • If you've tightened security on your systems so that *PUBLIC is set to *EXCLUDE by default on system commands and you want to install CCSS products, after installation and before starting the product, check that the product’s user profile, which is specified during installation (default ‘MSM’), has been granted *USE authority to the commands CRTOUTQ and CHGJOBD, and that it also has authority to the product’s subsystem description.

 

QMessage Monitor—Version 8

System Requirements

Before attempting installation onto either the IBM i or the PC, check that your hardware and software meet the minimum requirements set out below.

IBM i Requirements

  • Hardware: At least one partition running IBM i
  • Software: V5R4 or higher

PC Requirements

  • Hardware: An IBM (or 100% compatible) PC
  • Software: Windows 7 or higher

Important Notes

  • Upgrades: It's recommended that you perform a backup of the QMessage Monitor product library on the host system in the days before the upgrade.

  • For information on mandatory and optional PTFs, see "QMessage Monitor PTF Requirements."

  • Upgrades: If you use QRemote Control in addition to QMessage Monitor, stop all QRC servers before commencing the QMessage Monitor install process.

  • Upgrades: Audit Journal messages UCD0001 and UCD0002 have been expanded using UCD0003–UCD0005. If you've defined automated response records for the former IDs, we recommend initially amending those automated responses to use a message ID range of UCD0001–UCD0005 to avoid any issues.

  • Upgrades: If you used the Activity Log archiving feature (command MMARCLOG) in QMessage Monitor version 7 or earlier, then after upgrading to version 8, you'll need to convert any historical archive files using the supplied command MMCVTLOG.

  • If you use the Automated Response Trace (Reply Trace) functionality, stopping the product on the host system will take longer—up to a few minutes—as the trace file is reorganized during the product shutdown.

  • If you're using HA software, ensure that libraries MMFIX and MMUPG are excluded from replication. This ensures that the upgrade process will run smoothly.

 

QRemote Control—Version 4

For information on the requirements for QRemote Control, see "Installing QRemote Control."

For upgrade instructions, see "Upgrading QRemote Control".

 

 


Still have questions? We can help. Submit a case to Technical Support.

Last Modified On: January 10, 2018