Issue

Unable to create users with special characters in the username. For example, a period (.).

When trying to create a user with a special character in the username, you may get an error similar to this:

BoKS# mkbks -l WEB_HOSTS:john.doe -s /usr/bin/ksh -h /home/john.doe -u 2000 -g 1234

Invalid character(s) in username

Resolution / Workaround

The default valid special characters for a UNIX user in BoKS are the dash (-) and underscore (_). Upper/lowercase letters and digits are always allowed. The colon (:) and comma (,) are never allowed.

To permit an additional special character, such as a period (.), you will need to add the variable LOGIN_SPECIAL_CHARS to the $BOKS_etc/ENV file on your BoKS Master. When defining this variable, you must add the new character you desire (i.e. "."), as well as the default special characters you still want to be able to use.

For example, to add a period (.) and also still allow the dash (-) and underscore (_), you would add the following line to the ENV file:

LOGIN_SPECIAL_CHARS=. - _

If you leave off the dash (-) and underscore (_), they will no longer be defined and will become invalid. Setting this variable overrules the defaults and defines a new set of valid special characters.

Note that for BoKS 6.7 the variable LOGIN_SPECIAL_CHARS is only available if you have applied the hotfix HFBM-0042 (for mkbks, modboks and bccasd) and/or HFBM-0064 (for adsync).

See also


Still have questions? We can help. Submit a case to Technical Support.

Last Modified On: May 25, 2018