Issue

suexec does not handle wildcards correctly since the to-user path is not used.

For example:

suexec -u root mkfs

may give the error "Program mkfs not found" since suexec was still using the from-user's path.

Resolution / Workaround

In order to have CLI wildcards processed correctly by suexec it should be run with to-user environment turned on which is a setting you can specify for the Access Route in FoxT Control Center, or by adding the -m suexec_touserenv modifier when setting up the Access Route using routeadm or ttyadmin.


Still have questions? We can help. Submit a case to Technical Support.

Last Modified On: May 25, 2018