Issue

The upgrade_client program for BoKS version 7.2 does not include sufficient checks on the prerequisites for installation of the new BoKS Server Agent version, including checking whether “strings” is installed and the status of SELinux.

If any of these prerequisites are not met, the upgraded system may not function correctly.

Resolution / Workaround

The BoKS Manager 7.2 packages have been updated as of April 25, 2019 so the upgrade_client program now includes the necessary checks for installation prerequisites.

If you are upgrading BoKS Server Agents to version 7.2 using upgrade_client it is recommended to download a version of the package from the HelpSystems Community Portal in order to ensure that you are using the updated version.


Still have questions? We can help. Submit a case to Technical Support.

Last Modified On: June 28, 2019