Overview

InterMapper provides a complete set of tools to the user for investigating, understanding and troubleshooting unexpected results.

Log files, detailed logging and debugging, helper applications, and documentation in the User Guide and Forumall provide additional information about the operation of InterMapper. The Support page has links to these and other resources.

If the user isn’t able to determine the problem, InterMapper makes it easy to pass information needed to diagnose problems to technical support, including logs, screenshots, and other files using the Send Feedback tool.

This training session will describe how to collect information for troubleshooting, and the type of information that helps the support engineers to efficiently provide assistance in case of problems.

The Problem Statement

Certain information is very useful in analyzing problems.

Environment

            I’m using InterMapper RemoteAccess 5.8.2 in an OS X 10.10 environment. We recently upgraded from IMRA 5.8.2…

Noting the InterMapper release helps determine whether the problem may have been fixed in a later release as shown in the Release Notes:

InterMapper® 5.8.2b2 - 30 January 2015

  • [BUG FIX] Built-in probes now include an HTTPS version of the Follow Redirect probe. (103907)

Symptom

                        My local InterMapper Server requires me to log in instead of just opening the Map List.

If the problem is being sent to the reseller or tech support for assistance, a specific description of the problem makes finding the solution faster and prevents misunderstanding.

Steps taken so far

            I checked the User Guide and couldn’t find how to change this behavior.

When reporting a problem, send a description of what steps were taken to produce the problem and what was done to investigate it. If troubleshooting produced additional data, send that also (see the section about the Send Feedback tool below).

Log Files

InterMapper logs information about monitoring and about the operation of InterMapper. These are provided for user understanding and as troubleshooting tools.

Logs for InterMapper are found in the folder InterMapper Settings/InterMapper Logs on disk. The location of InterMapper Settings varies by host Operating System and is given here.

What is in the log files

    Client log (local console or RemoteAccess)

Using the menu option Help > Diagnostics > Client Debug Log will open a window showing the client debug log, and allow the log to be saved to file. The client debug log shows changes to the map and communication between the GUI and the InterMapper server. The client log is useful if the response from the GUI is the problem, and for diagnosing communication problems with the server, among other uses.

 

 

        <KU_log, object=L1860788, value=03/25 10:53:51 **** No response from DNS 10.0.0.1 when resolving '192.168.1.217' to a name.>
1332687234547 [AWT-EventQueue-0] (127.0.0.1:8181)
        <KU_log, object=L1860788, value=03/25 10:53:54 **** No response from DNS 10.0.0.1 when resolving '192.168.1.217' to a name.>
1332687238369 [AWT-EventQueue-0] (127.0.0.1:8181)
        <KU_log, object=L1860788, value=03/25 10:53:58 link util >= 50 (62.8%) : [2] Backbone - 2>

 

    Event log

Using Window > Logs > Event Log will open a log showing polling results, changes in device status (a device state change to up, down, warning, critical, etc.), notifier launch, SNMP traps received, and other information about changes to monitored devices.

Certain types of operational errors will be logged in the event log, such as problems executing notifiers.

 

 

03/25 10:50:44 **** No response from DNS 10.0.0.1 when resolving '10.168.1.45' to a name.
03/25 10:50:49 link util >= 50 (51.2%) : [8] Atlanta - Demo link 8
03/25 10:50:58 link UP : [5] Backbone - 5
03/25 10:50:58 link util >= 50 (60.6%) : [5] Backbone - 5

 

    Server debug log

To open the server debug log, use Window > Logs > Debug.

The server debug log is filled with messages showing operation of the InterMapper server. It may also be used to show detailed debugging, when the Help > Diagnostics > Detailed Logs options are selected. 

Detailed Log options for SNMP

This log contains debug information, and is not intended for monitoring normal operation. Many of the messages in this log will be confusing to the user if used as a monitoring tool. It is recommended that the server debug log be used as a debugging aid instead.

    System_Profile.txt

The system profile is a special-purpose log generated only by the Send Feedback tool. It is not available for viewing unless this tool is being used to send a report to technical support. It contains information about the InterMapper installation, the InterMapper host, version data for Java, and a history of GUI functions accessed, to help in debugging.

    IMDC

The components of InterMapper DataCenter each log information about their operation. Access to these logs is available through links in the InterMapper DataCenter web interface. The logs themselves are available in the location described here.

The InterMapper DataCenter web interface

InterMapper DataCenter (imdc.log)

The top-level log for InterMapper DataCenter, this log gives information for debugging the IMDC server and checking its operation.

 

 

2012-03-25 12:23:49    CONN Connection from 127.0.0.1 was automatically authenticated.
2012-03-25 12:23:49    CONN IMDC server authentication succeeded.
2012-03-25 12:23:49    CONN Sent <KR id='3' response='200'>rspauth=df1bc616ddaad92e28966612feefc5eb</KR>
2012-03-25 12:28:01    INFO WEB: An admin user has logged into the web admin interface.

 

InterMapper Authentication Server (imauth.log)

This log gives information about the actions involving the authentication server in InterMapper DataCenter. This server may also be used to control user access in InterMapper and InterMapper DataCenter, if this has been configured in InterMapper.

2012-03-25 12:23:49    CONN Connection from 127.0.0.1 was automatically authenticated.
2012-03-25 12:23:49    CONN IMDC server authentication succeeded.
2012-03-25 12:23:49    CONN Sent <KR id='3' response='200'>rspauth=df1bc616ddaad92e28966612feefc5eb</KR>
2012-03-25 12:28:01    INFO WEB: An admin user has logged into the web admin interface.
2012-03-25 12:28:49    CONN Received <KC_getproperty id='1' name='authtypes'></KC_getproperty>

InterMapper Database Log (imdatabase.log)

The database log shows operation of the built-in database in InterMapper, if in use. It is most often used as a status check if the status line on the IMDC interface indicates that the expected transactions have been suspended.

2012-03-25 12:33:32    CONN IMPORT (JEDI): Import complete for current reports (703 rows, 18573 bytes, 1.861000s elapsed)
2012-03-25 12:33:49    CONN Received <KC_registerserver fullpoll='1800' oldprofile='Now' enable='true' force='false' uuid='1fac457e-768c-0826-5204-bbf1498477e8' name='JEDI'

Using Technical Support - The Send Feedback tool

The Send Feedback tool

When local investigation and troubleshooting has not provided the required solution to the issue, technical support is available. The user may either email their reseller (if applicable) or Dartware technical support. The email address for technical support for InterMapper is support@intermapper.com .

The most direct and easiest method is to use the Send Feedback tool in the Help menu. Entering contact information at the top of the Send Feedback screen is important because it allows tech support to respond to the problem. Unless the user includes an email address, the tech support engineer will not know who to contact to help with the problem. The subject line should mention something about the problem, in a few words.

 The Send Feedback tool opens on the Summary tab, which contains a box labeled “Steps to Reproduce” for listing the problem and how to recreate it, if known. This box is also useful for including information about troubleshooting steps which have been taken. Also included is a check box for sending a screenshot.

The logs tab in the send feedback tool allows the user to send log information to help with troubleshooting. The log files contain useful data which may identify the issue without the need for further questions or investigation. The Client log is sent by default.

Log selection in Send Feedback

The System tab in Send Feedback shows the contents of the System Profile mentioned previously in the Logs section.

The Files tab in Send Feedback allows the user to send additional files (exported maps, notifiers, or data files).

When the contact information and problem description have been entered, and data to be sent has been selected, press the Submit button to send the Feedback to Dartware Technical Support (this only requires Web access – the data is sent using HTTP).

The Send Feedback mechanism is for reporting user problems, bugs, and for requesting enhancements to InterMapper. User problems are addressed immediately. Bug fixes are incorporated as soon as possible in the release cycle (the following release if possible).

Enhancement requests are compiled, reviewed by design and development, prioritized and then designed, coded, tested, and released. Some minor enhancements appear fairly quickly. Major enhancements may be planned for implementation in future versions and logically grouped with related design changes to maintain product stability and logical product evolution.

Exporting data using the file menu

Exporting data can be useful for many reasons, including providing resellers with data and using Dartware technical support. The following sections discuss exporting various data and files.

Maps

A screenshot of the map will often provide the information needed to understand the problem, if the issue requiring assistance concerns maps.

In other cases, it may be better to also send a copy of the map itself. The File > Export > Map menu option allows the user to save a copy of the map. This file will include the devices, probes, notifiers, and other information for the selected map.

Datafiles

Exporting Map Data

The File > Export > Data menu option allows the user to save data in a format which can be used in a spreadsheet, or imported into other tools.

Device Data

Exporting device data is useful for showing specific information about devices on a map. It is usually used for exporting data to another map. For technical support purposes, it is usually better to send the map by exporting it.

Notifiers

The data export option allows the user to export data about rules for launching notifications. This is helpful if the problem is that notifications are not received, or if they are received unexpectedly.


Still have questions? We can help. Submit a case to Technical Support.

Last Modified On: December 10, 2016