1. Using Autodiscovery

Use the Autodiscovery function to create an initial network map:

  1. From the File menu, choose New. The New Map Constructor window appears.
  2. Enter a map name and click Next.
  3. Click to choose Autodiscovery, then click Create. The Automatic Device Discovery dialog appears, as shown below.
  4. Enter a host name or IP address you want to use as the starting point for autodiscovery. A name is suggested for you. It is the DNS name, or IP address of a router, or if there's no router, the computer InterMapper is running on. Use the default value, or enter any of the following:
  • A DNS name
  • An IP address (if you want to create a map of another part of a network). If you enter the name or address of an SNMP-speaking router, InterMapper draws interconnections to other routers in the network more quickly
  • A WINS name

If you have SNMP-speaking devices in your network, specify an SNMP Community string.
.  Select your Discovery Options, as explained in The Auto-Discovery Window below.
      7.  Click the Filter button to set a filter for the discovery.
      8.  Click OK to start the Auto-discovery process. A Discovery Status bar appears as shown:


      9.  As the network is scanned, discovered devices appear in the current map (or in a list if you have cleared the Automatically Layout check box.)       When InterMapper has found all the devices within the specified subnet, the Discovery Status bar disappears.
 

  • Click the Map View button near the upper left corner of the Map window to view your network as a map, showing devices and networks as icons, with the interconnections between them.

To stop the Autodiscovery process:

  • Click the Cancel button. The discovery process is stopped, and no new devices or networks are added. All devices added before you stopped the process remain in the list.


The Automatic Device Discovery Window

You control the starting point, the SNMP Community string, the breadth of the network search, and the kinds of devices that are automatically added to the map using this window.
 


The Automatic Device Discovery window

  • Starting host name – The DNS name, IP address, or WINS name of a device to use as a starting point for the autodiscovery.
  • Specify an SNMP community -The SNMP Read-only community string to be used to interrogate all devices. (InterMapper will read SNMP information using the community string you enter. This is ‘public’ by default)
  • Stay within NN hops of starting device - Stops autodiscovery after InterMapper has searched the specified number of hops from the starting device.
  • Scan for devices on all networks - Specify which kinds of devices should be automatically added to the map. Click to check this box, or click Edit Filters to open the Network Scanning window.
  • Click Automatically layout to let InterMapper layout the map automatically.
  • Click Start Discovery to initiate a scan of the specified host.


The Network Filter Dialog

Check the filters you want to use to add devices to the map:

 

  • Active - InterMapper performs a complete IP address scan for each network. A device is added for each IP address that responds.
  • Named - Each IP address in the subnet is looked up in the DNS. If a corresponding name is present, the device is added to the map.
  • SNMP - InterMapper sends an SNMP GetRequest to each address in the range. Any device that responds is added to the map and uses the SNMP Basic Traffic probe. If the device does not respond to SNMP, the probe is set to Ping/Echo.
  • HTTP - If the device responds to an HTTP request, an HTTP probe is added to the device (along with SNMP Basic Traffic or Ping/Echo probe), and the device becomes a probe group.


What Happens During Autodiscovery?

During autodiscovery, InterMapper attempts to discover the parameters (IP address and subnet mask) of the subnet of the starting device. If it finds a router, it then scans all attached subnets, mapping all devices it finds, until it reaches the hop count specified in the Discovery Options section of the Automatic Device Discovery window and in the Network Scanning window. It then performs the following processes concurrently and iteratively until the specified limits are reached:

  • If InterMapper discovers an SNMP-speaking router, it attempts to discover what interfaces the router has, and what other routers are connected to those interfaces. InterMapper then queries each of the discovered routers for their connected networks, and begins autodiscovery on each network.
  • For each network or subnet discovered, InterMapper pings every address on that subnet to find more active or named devices.
  • When InterMapper finds a device, it uses several techniques to characterize it. For example, it sends SNMP queries (with the specified SNMP community string) to determine what kind of device is present.


Warning: In autodiscovery mode, InterMapper may ping or query every device address on a subnet. If your network has an intrusion detection system, autodiscovery may trigger your intrusion alarms. Be sure to check with the network manager before using this feature.

Note: It may take a long time to do autodiscovery on a large subnet (a Class A or B subnet). InterMapper limits its autodiscovery queries to two per second so that it doesn't overload any networks and thus it takes about 32,000 seconds (a shade under 10 hours) to scan that class B subnet (with 65,535 addresses) completely.
 

Tips for Speeding up Map Creation

  • To create your maps more quickly, you can type or paste one or more host DNS names, IP addresses, or WINS names into the Add Devices window (Insert menu). (WINS names must be preceded by "\\".) InterMapper immediately adds them to the map and connects them to the proper network.
  • You can also import a list of devices from a text file. For more information, see Importing Data Into Maps.


Below is a typical map after autodiscovery has finished.

Autodiscovered devices and networks. Routers are interconnected by links to networks.

 2. Adding Devices Manually


Add devices to your map manually using the Device command, available from the Insert menu or the Add Device(s) command, available from the context menu.

To add devices manually:
 

  1. Make sure the map is in Edit mode.
  2. From the Insert menu, choose Device..., or Right/Ctrl-click in the window and choose Add Device(s) from the context menu. The Add Devices window appears, as shown below.
  3. Enter the device names and/or addresses as shown below.
  4. The device(s) will be monitored with the indicated probe. To select a different probe type, click Choose and select a probe as described in Select Probe Window.
  5. Click Add. All devices entered are added to the map.


Note: If you enter a DNS name, the device is added to your map only if a DNS entry can be found.
 

Add Device(s) window.

 

  • Enter one or more host names or addresses - Enter individual host names or addresses or paste a list of DNS names, IP addresses, WINS names, AppleTalk NBP names, or AppleTalk addresses into this window. Entries must be separated by commas or by whitespace characters, such as spaces, tabs, or carriage returns. You can copy a list of host names and addresses from a text file or from a traceroute program. You can also use WINS names (preceded by "\\"). For each entry that responds, a device is added to the map.
  • Probe Type - Shows the type of probe currently assigned to the device. Click Choose to open the Select Probe window and choose a different probe.
  • Click Add to add the devices to the map.


Note: If any of the device names cannot be resolved (if a device name is not configured in your domain name system server) or if a device cannot be tested with the selected probe, don't worry; you'll get a chance to correct the entry.

IPv6 Note: To ensure that when possible, host names are resolved to IPv6 addresses rather than IPv4 addresses, enclose the host name in square brackets ([]) as shown in the example.

Create top-level map

InterMapper can have top-level maps that indicate the most serious condition of a sub-map.
 

  • Open your top-level map and position it and the Map List so you can see both windows.
  • Drag the icon for any sub-map from the Map List into main map. You'll see the probe configuration window appear. Click OK.
  • Drill down by double-clicking the new icon on the top-level  map. You'll see the new sub-map open up.

 

3. Using Layer 2 to construct physical network maps.

In the Window Menu select Device List and click the Layer 2 icon

Highlight the switch to switch connections and right-click (or Ctrl-click) ‘copy’.

Device List screen
 

 

 


Open a new map (File, New Map), give it a name, click Next and select Manual Entry.  Click on Create and cancel the Add Devices window.

Paste the switch to switch information into the empty map.



Open Edit Menu > Map Settings.  Select Monitoring / Layer 2 Features.  Check Enable Layer 2 features for this map. Automatically change this map to show Layer 2 connections should also be checked.  Click on Change Now.



Then, go to the Format Menu and select Arrange > Organic.   This will result in a connected backbone map:



Now, go back to the Layer 2 view, filter on a switch, highlight the endpoint devices and copy and paste them into the map.  Repeat the Make Layer 2 connections process.



Repeat the process for all the switches:


 

4. Map Layout and Design Tips and Tricks

 

Making Attractive Maps

There are a number of techniques for making the maps look more attractive, or to convey more information. Things to try:

  • Drag items around to match the way you think of your network. Lines between devices "rubberband" to preserve the interconnections.
  • Add a background image and then position devices as you like over the image. Simply drag a PNG, JPEG, or GIF image into the map window to add it, or choose Edit > Map Settings
  • Select different icons and shapes for devices Choose Format > Icon to pick new icons for the devices.
  • Change labels on devices The label is the text that appears in/next to the icon on the map. To edit a device's label, choose Format > Label or Ctl/Cmd-L.
  • Arrange devices on the map Use different options in the Format > Arrange menu.
  • Align command The Format > Align (Ctl/Cmd-Shift-K) command aligns items vertically and/or horizontally.
  • Add a link between devices Select two devices, then Insert > Add link (Ctl/Cmd-E)
  • Connect multiple devices to a point Select the devices, then choose the context menu Attach to. Lines will rubberband, and stick to the object you next click.

Note: Links added in the two items above are cosmetic and will not contain meaningful data.


Still have questions? We can help. Submit a case to Technical Support.

Last Modified On: December 20, 2016