Performance degradation observed in Showcase 9.x has been traced to the use of J9 Java. In contrast, Showcase 8.0 uses IBM Classic Java and exhibits expected performance.

In server patch 9.2.0.1, a new configurable option allows the customer to select Classic Java for running Builder definitions, the Server itself, or both. This option is set in the showcase.cfg file and requires that the server be restarted in order to take effect. This feature also requires the 9.1.0.6 client patch for Enterprise Server PC.

Note: IBM Classic Java is NOT supported for V7R1 or higher.

The following lines are now supported in the showcase.cfg file. If no entries are found, then ShowCase will default to IBM J9 Java for both Builder jobs, and the ShowCase Server:

showcasecorp.scserver.jvm.path=xxxx
showcasecorp.whb.jvm.path=xxxx

Possible values for xxxx are:
/QOpenSys/QIBM/ProdData/JavaVM/jdk60/32bit (for J9 JVM)
or
/QIBM/ProdData/Java400/jdk6 (for Classic JVM)

Note: The showcase.cfg file is located in the /<install_lib>/proddata/config directory of the IFS (where <install_lib> references the Showcase install library. The default is SCSERVER) .

Examples:

To set the Server JVM to J9:
showcasecorp.scserver.jvm.path=/QOpenSys/QIBM/ProdData/JavaVM/jdk60/32bit

To set the Builder JVM to Classic:
showcasecorp.whb.jvm.path=/QIBM/ProdData/Java400/jdk6

You can choose to run both Builder jobs and the Server using Classic or J9, or use J9 for Builder jobs and Classic for the Server, and vice-versa.

 

 

 

 


Still have questions? We can help. Submit a case to Technical Support.

Last Modified On: August 19, 2019