When installing both 32 bit (.i686) and 64 bit (x86_64) versions of the same library, they must be the same version. The error message: : libuuid-2.23.2-33.el7.i686 != libuuid-2.23.2-26.el7.x86_64 <<<<< error indicates that the versions are not the same. Note that i686 is 2.23.2-33 while x86_64 is 2.23.2-26. Installing i686 pulls the latest version of the 32-bit library. However, the 64-bit remains outdated. Either run the yum update command to update all existing libraries in the system or do it for an individual update on the mismatched version. When update is complete, resume the installation of the 32-bit library using the yum install libuuid.i686 command.


Still have questions? We can help. Submit a case to Technical Support.

Last Modified On: March 31, 2020